Search found 13 matches

by jockeosth
Fri 03 Nov 2017, 23:54
Forum: Usage
Topic: Simulating impedance between two planes with decoupling
Replies: 2
Views: 1188

Re: Simulating impedance between two planes with decoupling

Hi Thorsten I hope you enjoyed the holiday :) I tried three different steps, but no noticeable difference at the low frequency end. change the excite frequency from 5GHz to 2GHz. change convergence limit from 40dB to 60dB. improved the grid resolution from lambda/16 to lambda/64. Not a big problem b...
by jockeosth
Fri 27 Oct 2017, 15:39
Forum: Usage
Topic: Simulating impedance between two planes with decoupling
Replies: 2
Views: 1188

Simulating impedance between two planes with decoupling

Hi! I like to use OpenEMS for PDN design so I started with a simple setup and later added one decoupling capacitor. First I only simulate two planes and observe the impedance. Z_vs_freq.png I expect the impedance to look capacitive for low frequency, reach a minimum and then the impedance to look in...
by jockeosth
Thu 17 Aug 2017, 11:54
Forum: Usage
Topic: Two Microstrip Lines
Replies: 6
Views: 2718

Re: Two Microstrip Lines

Hi woot. I think your mesh resolution is too big? If I do a diff(mesh.y) I see about 4200-4400 um. Your MSL is only 720um wide. I like to use the 1/3 2/3 rule and have at least 2 mesh lines inside the MSL and at least 1 line between the two MSL in the z-direction. It also seems your substrate is not...
by jockeosth
Fri 19 May 2017, 16:18
Forum: Usage
Topic: Signal integrity - Crosstalk between microstrips
Replies: 2
Views: 1574

Re: Signal integrity - Crosstalk between microstrips

Hi again, I found a comparative study of different EM-tools that include crosstalk as well. Using the same setup as shown here: http://www.pcdandf.com/pcdesign/index.php/magazine/10472-simulation-1512 I got the same results with OpenEMS (about 4.2%), as expected :) Before I found the comparative stu...
by jockeosth
Mon 15 May 2017, 23:10
Forum: Usage
Topic: Signal integrity - Crosstalk between microstrips
Replies: 2
Views: 1574

Signal integrity - Crosstalk between microstrips

Hi! I start to make a setup to calculate the coupling between two transmission lines. I like to use the S-parameters to convert to time-domain crosstalk values. From the simulation I get approximately the expected results. When using spacing == line width for 50R line I should get about 4.4% near-en...
by jockeosth
Sat 13 May 2017, 23:39
Forum: Usage
Topic: Simple microstrip simulation and meshing
Replies: 4
Views: 2267

Re: Simple microstrip simulation and meshing

Thanks for your reply Thorsten. I will change the lumped port to cover the width of the MSL. I used the lumped port because it is easy to use and later on I will expand the design to cover non-symmetrical striplines too. But I will consider to add the MSL port for better performance in MSL cases :) ...
by jockeosth
Sat 13 May 2017, 20:12
Forum: Usage
Topic: Simple microstrip simulation and meshing
Replies: 4
Views: 2267

Re: Simple microstrip simulation and meshing

Hi! Late replay to my own post. Problem was I forget to add a grid point in the middle of the line where the lumped ports connect. Moreover, I added an airbox with lambda/4 length at f_max. It seems to improve the results as suggested in the http://openems.de/index.php/FDTD_Mesh page. If I remember ...
by jockeosth
Fri 05 May 2017, 21:59
Forum: Usage
Topic: Simple microstrip simulation and meshing
Replies: 4
Views: 2267

Simple microstrip simulation and meshing

Hi! I have a simple microstrip with lumped ports. For some values on the resolution of the mesh and/or widths of the strip the simulator converge and for others it get stuck. Probably I miss something about the mesh? For example changing the strip_width from 240 to 185 makes the simulator stuck. Any...
by jockeosth
Mon 06 Feb 2017, 23:00
Forum: Usage
Topic: Stripline simulation - setup problem?
Replies: 11
Views: 4659

Re: Stripline simulation - setup problem?

Hi again! The updated mesh solved the problem. I need to be more careful with the mesh definitions :) I update the code to run with stripline port with termination in lumped-R or in a PML-8. When I use lumped-R I get coupling as expected. However, if I use PML to terminate the ports I don't get the ...
by jockeosth
Sun 05 Feb 2017, 21:11
Forum: Usage
Topic: Stripline simulation - setup problem?
Replies: 11
Views: 4659

Re: Stripline simulation - setup problem?

Hi Thorsten! I try simulate a coupler in stripline, basically two lines close to each other. It seems to work but I have enter a problem that the simulator reporting "nan" for the energy when simulating for some specific values of the spacing between the two lines. For example with a spacing of 70um...