Search found 10 matches

by gobers
Tue 13 Dec 2016, 18:58
Forum: Install
Topic: INstallation with VTK Version other than 6.1
Replies: 13
Views: 17985

Re: INstallation with VTK Version other than 6.1

Hi,
feel free to change them. I am new to git and therefore much focusing on the process, not the contents ;-)
gerald
by gobers
Tue 13 Dec 2016, 15:56
Forum: Install
Topic: INstallation with VTK Version other than 6.1
Replies: 13
Views: 17985

Re: INstallation with VTK Version other than 6.1

OK, I created the pull requests, all separately, if there is a way to do this in one step, please let me know.#
Thanks for your effort and work
Gerald
by gobers
Tue 13 Dec 2016, 08:07
Forum: Install
Topic: INstallation with VTK Version other than 6.1
Replies: 13
Views: 17985

Re: INstallation with VTK Version other than 6.1

HI, about (4). AppCSXCAD: Yes it is building the last binary that fails, and yes, AppCSXCAD needed the hdf5-stuff, at least the way I built it with not using the script, but the "mkdir build && cd build && cmake ../ && make AppCSXCAD" chain of commands (gives better access to logs and errors). I wil...
by gobers
Mon 12 Dec 2016, 15:37
Forum: Install
Topic: INstallation with VTK Version other than 6.1
Replies: 13
Views: 17985

Re: INstallation with VTK Version other than 6.1

Hello, I got it to work also on the other machine (SL7, VTK7.1), this is what I did (I do not know, if these are just hacks or proper solutions): 1. in all subdirectory CMakeLists.txt I added "C" in e.g. PROJECT( AppCSXCAD CXX C). cmake threw an error, that it couldn't execute a try_compile, because...
by gobers
Mon 12 Dec 2016, 09:00
Forum: Install
Topic: INstallation with VTK Version other than 6.1
Replies: 13
Views: 17985

Re: INstallation with VTK Version other than 6.1

Hello Thorsten, this is what cake says: CMake Warning: Manually-specified variables were not used by the project: CMAKE_HAVE_PTHREADS_CREATE and the end-result is the same. I got openEMS to work on a different machine (rather clean Debian Jessie stable distro). Therefore this helps a little bit, but...
by gobers
Sun 11 Dec 2016, 21:02
Forum: Install
Topic: INstallation with VTK Version other than 6.1
Replies: 13
Views: 17985

Re: INstallation with VTK Version other than 6.1

Hello Thorsten, Yes, cmake runs through fine. Makefiles are generated make is aborting with the error message that it cannot find "-lpthreads" (I believe the "s" at the end is relevant). And I do not have libpthreads.so, I do have libthread.so. I have little experience with cmake. Usually, cmake tes...
by gobers
Sun 11 Dec 2016, 11:04
Forum: Install
Topic: INstallation with VTK Version other than 6.1
Replies: 13
Views: 17985

Re: INstallation with VTK Version other than 6.1

Hi Thorsten, thanks for looking at this. I fully understand, that you cannot support all possible configs on earth. However, it seems I was mistaken, it is make taht is failing with the message: --------------------------- /usr/bin/cmake3 -E cmake_link_script CMakeFiles/cmTC_77a8d.dir/link.txt --ver...
by gobers
Fri 09 Dec 2016, 20:11
Forum: Install
Topic: INstallation with VTK Version other than 6.1
Replies: 13
Views: 17985

INstallation with VTK Version other than 6.1

Hello, running the script as well as cmake (and make) separately, I get CMake Warning at CMakeLists.txt:124 (find_package): Could not find a configuration file for package "VTK" that is compatible with requested version "6.1". The following configuration files were considered but not accepted: /usr/...
by gobers
Thu 10 May 2012, 14:43
Forum: Install
Topic: Octave conflict with hd5
Replies: 4
Views: 8170

Re: Octave conflict with hd5

Hi, The problem is above the last error message. It reads as if it cannot find mkoctfile, but actually it can. However, the (shell) process mkoptfile terminates with the error message that cc1plus.exe cannot deal with the option "-fno-keep-inline-dllexport". And that is really strange, since to me t...
by gobers
Thu 10 May 2012, 13:49
Forum: Install
Topic: Octave conflict with hd5
Replies: 4
Views: 8170

Re: Octave conflict with hd5

Hi Thorsten, thanks for the quick response. I did "setup" on a Octave 3.2.3 where now everything works OK, thanks again. However, on 3.6.0 and 3.6.1 I get the following error message: octave:2> setup setting up openEMS matlab/octave interface compiling oct files cc1plus.exe: error: unrecognized comm...