make for CSXCAD failed

Install support for openEMS

Moderators: thorsten, sebastian

apaj
Posts: 24
Joined: Wed 06 Apr 2016, 10:51

Re: make for CSXCAD failed

Post by apaj » Wed 06 Apr 2016, 10:56

Hello everybody,

let me join in on expressing gratitude to Thorsten for sharing this software with the community.

I run into the same problem with the Polyhedron, so please find attached the build log.

My system is CentOS 6.5, and the additional software versions are as follows:

VTK 7.0.0
GMP 6.1.0
CGAL 4.8
Boost 1.60.0
MPFR 3.1.4

Apologies if I forgot something, please do let me know if any additional information may help resolving the issue I am having.

Best regards,
apaj
Attachments
build_20160406_114530.log
(8.67 KiB) Downloaded 634 times

felipebm
Posts: 23
Joined: Wed 10 Dec 2014, 14:15

Re: make for CSXCAD failed

Post by felipebm » Wed 06 Apr 2016, 14:34

Hi apaj and welcome aboard!

Have you tried installing the last version? Look here for the source tar-balls:
http://openems.de/download/src/

At the time I wrote this, the last version is the one modified at 22-Sep-2015. I'm working with that version and works without trouble.

Good luck,
Felipe.

apaj
Posts: 24
Joined: Wed 06 Apr 2016, 10:51

Re: make for CSXCAD failed

Post by apaj » Wed 06 Apr 2016, 15:09

Thank you, Felipe.

Actually, the latest version was modified on 14-Oct-2015, also marked as "current". Thus, that was the one I installed first and that one produced the log I uploaded in my previous post.

Nevertheless, I tried the one you proposed (modified 22-Sep-2015), unfortunately, to the same end - the exact same error is reported.

Do you maybe have any other ideas?

Best regards.

felipebm
Posts: 23
Joined: Wed 10 Dec 2014, 14:15

Re: make for CSXCAD failed

Post by felipebm » Wed 06 Apr 2016, 15:39

Have you tried with the git repositories?

http://openems.de/forum/viewtopic.php?f ... t=10#p1676

best,
Felipe.

thorsten
Posts: 1430
Joined: Mon 27 Jun 2011, 12:26

Re: make for CSXCAD failed

Post by thorsten » Wed 06 Apr 2016, 21:03

Hi,

Felipe is right, e.g. support for vtk 7 was added just some weeks ago. Use the latest git tree...
But your log seems to indicate a problem with CGAL. Can you please try the latest tree and attach the log again?
Maybe in CGAL 4.8 has some issues with the current version too. Did cmake find CGAL correctly?
What surprises me is that all this brand new libraries are included in such an old CentOS ???

regards
Thorsten

apaj
Posts: 24
Joined: Wed 06 Apr 2016, 10:51

Re: make for CSXCAD failed

Post by apaj » Thu 07 Apr 2016, 10:09

Hello,

thank you both.

No, they are not included, I did that part. I do have CentOS 7 running on my laptop, but, unfortunately, over the period I've had it, I had more issues than I enjoy - thus the machine I do work on remains good old 6.5.

It took me some time to get it done, but I've managed and, yes, cmake found CGAL.

Today and tomorrow I have a really busy schedule, thus I am not sure when will I get to installing the git version - but I will let you guys know how it goes.

Best regards.

apaj
Posts: 24
Joined: Wed 06 Apr 2016, 10:51

Re: make for CSXCAD failed

Post by apaj » Wed 15 Jun 2016, 15:11

Hello guys,

I am sorry for such a long gap between my posts, but among my obligations at work I completely drifted. However, now I am back on track and I would like to get this working.

In that context I used the git version to the same result, unfortunately - please find attached the log file.

Is there anything else I can do with the Polyhedron issue?

Thank you very much.

Best regards.
Attachments
build_20160615_160646.log
(11.06 KiB) Downloaded 553 times

thorsten
Posts: 1430
Joined: Mon 27 Jun 2011, 12:26

Re: make for CSXCAD failed

Post by thorsten » Wed 15 Jun 2016, 21:28

Hi,

I recently successfully compiled openEMS on a RHEL 6.8. It was not much fun and I really cannot recommend RHEL 6.x
CGAL and boost was both given me quite a headache...
I can only recommend to switch to a newer Linux Distri...

From the message it looks like CGAL is still not correctly found...

regards
Thorsten

apaj
Posts: 24
Joined: Wed 06 Apr 2016, 10:51

Re: make for CSXCAD failed

Post by apaj » Thu 16 Jun 2016, 16:44

Ok, thank you Thorsten.

Once again, thank you for providing this software to all of us.

I'll get back with some more specific questions once I have openEMS running successfully on another OS.

Best regards.

inname
Posts: 3
Joined: Tue 04 Oct 2016, 13:43

Re: make for CSXCAD failed

Post by inname » Wed 05 Oct 2016, 09:48

Good day.
Thank you for an excellent program.
Sorry for my English, I use a translator.


Faced with the problem of installation, before going fine.
Debian GNU / Linux System 8.6 (jessie)
libhdf5-dev 1.8.16 + docs-8 + b1
Constantly he gave the assembly that it can not find the header file hdf5.h
As it turned out CmakeFindHDF5.cmake changed and could not properly connect the header and library files.

Replaced in the following lines CmakeLists.txt:

Code: Select all

find_package (HDF5 1.8 COMPONENTS C HL REQUIRED)
INCLUDE_DIRECTORIES ($ {HDF5_INCLUDE_DIR})
link_directories ($ {HDF5_LIBRARY_DIRS})
on

Code: Select all

find_package (HDF5 1.8 COMPONENTS CXX HL REQUIRED)
INCLUDE_DIRECTORIES ($ {HDF5_INCLUDE_DIRS})
link_directories ($ {HDF5_LIBRARIES})
The project folders: CSXCAD openEMS

Thereafter, the assembly is successful.

Logs to correct the error and logs after correction enclosing
Attachments
build_20161004_135158.log
Good
(140.09 KiB) Downloaded 500 times
build_20161003_165140.log
error
(5.39 KiB) Downloaded 496 times

Post Reply