AppCSXCAD incorrect render on Debian 9

Install support for openEMS

Moderators: thorsten, sebastian

bveidt
Posts: 13
Joined: Sat 26 May 2018, 00:07

Re: AppCSXCAD incorrect render on Debian 9

Post by bveidt » Sat 22 Jun 2019, 00:35

Here's the xml file for the solid model rendering which I posted earlier.
Attachments
horn_ant.xml
(11.95 KiB) Downloaded 116 times

bveidt
Posts: 13
Joined: Sat 26 May 2018, 00:07

Re: AppCSXCAD incorrect render on Debian 9

Post by bveidt » Mon 24 Jun 2019, 20:28

I just remembered that I have openEMS on a VirtualBox instance of Ubuntu 16.04. I booted it and yes, I have openEMS 0.0.35 installed. AppCSXCAD renders solid models correctly.

Here are the vtk packages installed on 16.04:
vtk-libs-installed-16.04.png
vtk-libs-installed-16.04.png (14.41 KiB) Viewed 1967 times
Although some of the libs are version 5 and others version 6, if I run

Code: Select all

ldd AppCSXCAD | grep vtk 
this shows that the program is linked to version 5 libs.

On Ubuntu 18.04 all vtk libs are version 6.

Let me know if you want me to check anything else. It is easy for me to run Ubuntu 16.04 and compare with the installation on 18.04.

bveidt
Posts: 13
Joined: Sat 26 May 2018, 00:07

Re: AppCSXCAD incorrect render on Debian 9

Post by bveidt » Sat 20 Jul 2019, 02:25

For what it's worth, here's the ldd output for AppCSXCAD, version v0.0.35. Any differences from your build?
Attachments
ldd-AppCSXCAD-16-07-2019.txt
ldd output for AppCSXCAD, version v0.0.35.
(13.73 KiB) Downloaded 128 times

Post Reply