Page 1 of 1

Win:AppCSXCAD very slow on start after Spectre/Meltdown upd.

Posted: Mon 18 Jun 2018, 08:16
by Hale_812
It looks like AppCSXCAD got very-very slow on start after Spectre/Meltdown updates were applied.
Actually, I am not sure which updates affect this. AFAIK, every software that calls the core for any acl related operation too much experiences heavy performance drop now. Particularly in Pre-Win10 OSes, as MS says. And AppCSXCAD asks for rights elevation when started, and I don't know what else. So, probably that is a Spectre patch.
Are there plans to optimize the code for fixing this lag?

Re: Win:AppCSXCAD very slow on start after Spectre/Meltdown

Posted: Mon 18 Jun 2018, 20:22
by thorsten
I can't imagine that this really is the case. Especially since you can only refer to the 3D rendering which should happen only in the GPU in the first place? Maybe some 3D openGL driver issue?

Re: Win:AppCSXCAD very slow on start after Spectre/Meltdown

Posted: Mon 09 Jul 2018, 09:59
by Hale_812
I really don't know. I am not a programmer myself. I tried some basic things on C in the past, but not that advanced APIs.
I just had an idea that it may require to much control of privileges when talking with cross-platform API. And the slowdown happens exactly in that area, according to Microsoft.
At some moment I just found myself waiting for AppCSXCAD loading and responding to inputs too slow, much slower than before. All I remember is that I have installed spectre/meltdown updates around that time.

Re: Win:AppCSXCAD very slow on start after Spectre/Meltdown

Posted: Wed 11 Jul 2018, 04:26
by Hale_812
ow-ow-ow...
That was not the Spectre.

Dear Thorsten, what do you compile in \matlab\h5readatt_octave.o, and h5readatt_octave.oct?
What is that? Can it change, or be damaged in time?
Yesterday, APPCSXCAD stopped functioning totally. I was confused and reinstalled completely. Fresh downloaded and unpacked setuop works well. It is probable, something has happened to these files, as they had newest timestamp.

Re: Win:AppCSXCAD very slow on start after Spectre/Meltdown

Posted: Fri 24 Aug 2018, 04:24
by Hale_812
Looks like the problem is not in the APPCSXCAD itself, but in how it is intercepted by antiviruses after the Windows kernel update.
I have the same slowdown in MSSE, and in TrendMicro, and probably in ESET (however can not confirm for sure). Disabling any of these antiviruses lets the tool start normally. Enabling an antivirus results in 1-15 min. delay.