openEMS.de is back up again

News about openEMS

Moderators: thorsten, sebastian

thorsten
Posts: 1294
Joined: Mon 27 Jun 2011, 12:26

openEMS.de is back up again

Post by thorsten » Thu 08 Nov 2018, 21:12

Hi,

as some of you may have noticed the website "openEMS.de" was not reachable for some time.
The reason for that outage was that the site was still running on a virtual machine (VM) on an old Linux host PC.
That host PC started having problems and constantly shredding the VM.
Thus the website had to be moved to a new host.
This move has been (mostly) done now. The forum and main page was restored from the backups.
The old wiki is a different story. We have backups of it too, but I had planned to replace the wiki with some other kind of documentation.
Unfortunately this replacement is not available yet. Thus I'm not yet sure how to proceed.
In the next couple of days I will try to convert the old wiki into a static page, kind of as an archive.
Let me know what you think and I'm always grateful for some help in creating a better documentation for openEMS.

One positive outcome of this unplanned outage. A lot of users of openEMS expressed their concern that I might have abandoned openEMS and asked when the site would be back up. It is nice to hear that openEMS indeed is been used. On that note, please if you use openEMS, let me know. Write about your experience here in the forum or write me an email.

Update:
- The wiki has been transformed to a static page

regards
Thorsten

Hale_812
Posts: 144
Joined: Fri 13 May 2016, 02:54

Re: openEMS.de is back up again

Post by Hale_812 » Fri 16 Nov 2018, 07:20

>That host PC started having problems and constantly shredding the VM.
Virtualbox? It is a well known shredder of VM descriptor files. You have to put backup there and check for the consistency with a script every time VBOx is tarting your VM. Oracle (then Sun, Innotek) have this bug for longer than 15 years, and do not care at all.

Hale_812
Posts: 144
Joined: Fri 13 May 2016, 02:54

Re: openEMS.de is back up again

Post by Hale_812 » Fri 16 Nov 2018, 07:24

And thank you so much for coming back!

PaulUK
Posts: 55
Joined: Wed 28 Oct 2015, 14:23

Re: openEMS.de is back up again

Post by PaulUK » Tue 20 Nov 2018, 17:37

Thank you very much, Thorsten. I was able to get a new password but I'm unable to save any attatchments posted in the threads? I'm not sure if that applies to everyone or just me after the issue with the forum.

Just to say, I've been getting some more practice with openEMS and really liking it so far.

thorsten
Posts: 1294
Joined: Mon 27 Jun 2011, 12:26

Re: openEMS.de is back up again

Post by thorsten » Tue 20 Nov 2018, 18:51

I'm unable to save any attatchments posted in the threads?
Some phpBB files were missing for some odd reason. Should work now.
Virtualbox? It is a well known shredder of VM descriptor files.
Yes, but it was a known bug that this old Virtualbox version and Ubuntu kernel did not work on ext4. We were planning for years to migrate the webpage, but were too lazy when Virtualbox decided to force the issue ;)

Lets see how many hiccups are still left. So far I was able to fix them and keep up...

regards
Thorsten

HexAndFlex
Posts: 4
Joined: Sat 06 Oct 2018, 09:11

Re: openEMS.de is back up again

Post by HexAndFlex » Tue 20 Nov 2018, 19:47

Hi Thorsten,

Good to have the site back up and running again. I have been using OpenEMS to design a log spiral antenna for amerture radio users. I have been documenting the development on my blog and hopefully pursuading some rf enthusiasts to give it a go.

My blog is here https://hexandflex.com/2018/10/05/spiral-antenna-part-2-modelling-and-simulation-with-openems/amp/

I plan to release the .m code file in the not too distant future(hopefully with a short tutorial) so users can simulate it for themselves.

If you set up a donate system, i would be happy to contribute towards any ongoing development or hosting fees.

HexAndFlex
Posts: 4
Joined: Sat 06 Oct 2018, 09:11

Re: openEMS.de is back up again

Post by HexAndFlex » Wed 21 Nov 2018, 23:08

The main OpenEms.de site is still down for me btw. The forum working fine still.

thorsten
Posts: 1294
Joined: Mon 27 Jun 2011, 12:26

Re: openEMS.de is back up again

Post by thorsten » Wed 21 Nov 2018, 23:35

That is very odd. For me it all works fine... What does happen when you browse for openems.de?
Try directly: http://openems.de/start/index.php?show=home

regards
Thorsten

HexAndFlex
Posts: 4
Joined: Sat 06 Oct 2018, 09:11

Re: openEMS.de is back up again

Post by HexAndFlex » Thu 22 Nov 2018, 08:49

Hi Thorsten,

The link you provided works. :D

If I try http://openems.de it automatically redirects to http://openems.de/index.php/ which is a blank screen on my device.

thorsten
Posts: 1294
Joined: Mon 27 Jun 2011, 12:26

Re: openEMS.de is back up again

Post by thorsten » Thu 22 Nov 2018, 09:11

Maybe this is still are faulty permanent redirect. Browser store them forever and do not ask again. Try to clear your cache for openEMS.de.
Try on a a different browser or machine to check if this is the case.
At some point I was experimenting with redirects and ran into a similar issue...

Post Reply