vtkShaderProgram: Shader object was not initialized

Install support for openEMS

Moderators: thorsten, sebastian

Post Reply
piranha32
Posts: 2
Joined: Mon 22 Jan 2018, 11:13

vtkShaderProgram: Shader object was not initialized

Post by piranha32 » Mon 22 Jan 2018, 11:25

Hello,

I have a problem with CSXCAD on openEMS built from source downloaded from github. The simulator works fine, I can run most of the code from the tutorial pages, but AppCSXCAD crashes. The OS if Fedora 27, running on i9-7920X with 32GB of RAM, graphics card is NVidia GeForce GTX 1060 6GB and I'm using driver from NVidia, version 384.111.
Here is when I get when I try to run AppCSXCAD:

Code: Select all

$ LIBGL_ALWAYS_INDIRECT=y LD_PRELOAD=/usr/lib64/openmpi/lib/libmpi_cxx.so  ./AppCSXCAD
ERROR: In /builddir/build/BUILD/VTK-7.1.1/Rendering/OpenGL2/vtkShaderProgram.cxx, line 424
vtkShaderProgram (0x2c9a000): Shader object was not initialized, cannot attach it.

Segmentation fault (core dumped)
$
The same happens when I try to run AppCSXCAD from Octave.

VTK has been installed from binary package provided by the distribution:

Code: Select all

$ rpm -q vtk                                                                                                                                        
vtk-7.1.1-7.fc27.x86_64  

thorsten
Posts: 1393
Joined: Mon 27 Jun 2011, 12:26

Re: vtkShaderProgram: Shader object was not initialized

Post by thorsten » Mon 22 Jan 2018, 22:17

Hi,

unfortunatly I have not seen this error before. But from what I have googled it seems a nvidia and vtk7.1 problem?
https://bugzilla.redhat.com/show_bug.cgi?id=1496287

On Ubuntu I always only used vtk6.x (I think) and now I'm on Manjaro (Arch based) which has 8.x already...
I'm not sure what to do about it...

regards
Thorsten

piranha32
Posts: 2
Joined: Mon 22 Jan 2018, 11:13

Re: vtkShaderProgram: Shader object was not initialized

Post by piranha32 » Mon 22 Jan 2018, 22:36

Thanks. I did not find this one. I added my comment to the bug report.

Post Reply