Ubuntu installation failing due to VTK

Install support for openEMS

Moderators: thorsten, sebastian

thorsten
Posts: 1393
Joined: Mon 27 Jun 2011, 12:26

Re: Ubuntu installation failing due to VTK

Post by thorsten » Wed 26 Jun 2019, 18:26

I today was able to test this on a 18.04LTS Ubuntu and AppCSXCAD seemed to work fine.
I used the "libvtk7-qt-dev" package together with Qt5.9.x.
That means I really have no clue how I can fix this issue?
What versions of Qt and vtk are your AppCSXCAD build against? Check in Info-->About in the main menu...

bveidt
Posts: 13
Joined: Sat 26 May 2018, 00:07

Re: Ubuntu installation failing due to VTK

Post by bveidt » Wed 26 Jun 2019, 22:16

On my system:

Qt: 50905
vtk: 6.3.0
CSXCAD-Lib: 0.6.2

Perhaps I should upgrade vtk to version 7 and see what happens.

bveidt
Posts: 13
Joined: Sat 26 May 2018, 00:07

Re: Ubuntu installation failing due to VTK

Post by bveidt » Wed 26 Jun 2019, 22:39

Just finished building it against vtk7 and rendering is still wrong.

Qt: 50905
vtk: 7.1.1
CSXCAD-Lib: 0.6.2

Maybe vtk version is a red herring?

thorsten
Posts: 1393
Joined: Mon 27 Jun 2011, 12:26

Re: Ubuntu installation failing due to VTK

Post by thorsten » Wed 26 Jun 2019, 23:04

Latest build from git master?, because CSXCAD 0.6.2 does not sound like it...

Well vtk is doing the rendering and since the rendering is wrong I don't know what else it should be. Of course the graphics driver is another factor, as might be the desktop environment and I don't know what else...

dkozel
Posts: 1
Joined: Wed 26 Jun 2019, 22:51
Contact:

Re: Ubuntu installation failing due to VTK

Post by dkozel » Wed 26 Jun 2019, 23:16

I just want to mention that Ubuntu 19.04 has OpenEMS 0.0.35 packaged in the regular repository and I've just verified that it works wonderfully with the packaged Octave as well. It does look like the tutorial files haven't been packaged yet through.
https://packages.ubuntu.com/disco/openems

> sudo apt install openems octave

thorsten
Posts: 1393
Joined: Mon 27 Jun 2011, 12:26

Re: Ubuntu installation failing due to VTK

Post by thorsten » Fri 28 Jun 2019, 21:06

I just want to mention that Ubuntu 19.04 has OpenEMS 0.0.35 packaged in the regular repository
I was not aware of this. Very nice, unfortunately this version has a few known bugs. I really have to think about releasing 0.0.36. I always delayed it because I wanted to update the packages on windows. But my first attempt did not work as hoped...

@bveidt: can you confirm that with the latest github version and vtk 7.1.1 the rendering is still broken for you?

bveidt
Posts: 13
Joined: Sat 26 May 2018, 00:07

Re: Ubuntu installation failing due to VTK

Post by bveidt » Mon 08 Jul 2019, 23:35

Sorry for the delay, but I've been travelling.
I have built the git version and unfortunately AppCSXCAD still renders models incorrectly.
I could send you ldd output if that would help.
Here's the info panel:
git-version-info.png
git-version-info.png (78.81 KiB) Viewed 3897 times

Post Reply