Installing on Fedora version 33 (Red Hat Enterprise Linux)

Install support for openEMS

Moderators: thorsten, sebastian

Post Reply
Posts: 1
Joined: Thu 28 Jan 2021, 18:44

Installing on Fedora version 33 (Red Hat Enterprise Linux)

Post by GettingRichAgain » Thu 28 Jan 2021, 19:31

Installation on Fedora 33 succeeded. I used depending packages from the standard Fedora repository installation. (Package manager for Fedora is named "dnf" otherwise seems to be the same as "apt".)

Packages are named slightly differently. The developer versions are named pckgname-devel. The cgal packages are found with dnf list, but won't install unless typed CGAL at the install name.

Running the "does it work" Tutorials:

I used the default installation of Fedora 33, so it uses GNOME ver 3 desktop and Wayland graphics. (I don't remember which compositor Weston or Easton(?) )

The GUI raised by CSXGeomPlot does NOT appear under Wayland based desktop.

Invoking GNOME using GNOME XOrg mode CSXGeomPlot GUI works. {I deduce openEMS is an X-Windows based application :) }
Invoking KDE Plasma desktop mode works. [this week, KDE is rumored to be shifting to Wayland.] There are still lots of X based desktops available.

Following Tutorial path, I tried ParallelPlateWaveGuide.m
This FAILS with a vtk error at CSXGeomPlot invocation.
pathinfo..../bin/ Line 15 5679 segmentation fault core dumped.

So, which vtk version should be installed? {What keystrokes do I use to find what vtk version I have active today? Also vtk error mentioned java. I have the default opensource java from fedora packages. Do I need to install/activate the Sun Microsystems (Oracle) version of java?

Now to shovel snow off the driveway, 20cm deep overnight, remarkable but within "normal" range here!


Posts: 1479
Joined: Mon 27 Jun 2011, 12:26

Re: Installing on Fedora version 33 (Red Hat Enterprise Linux)

Post by thorsten » Sat 06 Feb 2021, 14:02


the openEMS GUI uses Qt and thus should be wayland capable in theory. Maybe your version was build against a too old version of Qt?
But I have not tried it myself yet, maybe vtk and/or openGL is the issue...
You should be able to start it on wayland using xwayland by using something like "-platform xcb" as additional argument for AppCSXCAD


Post Reply