Ubuntu --no-simulation option in RunOpenEMS does not work

Install support for openEMS

Moderators: thorsten, sebastian

Post Reply
MPCEngineer
Posts: 31
Joined: Thu 02 Sep 2021, 18:29

Ubuntu --no-simulation option in RunOpenEMS does not work

Post by MPCEngineer » Mon 06 Sep 2021, 13:34

Hi.

Installed the latest version of openEMS for Ubuntu using https://github.com/thliebig/openEMS-Project

The option --no-simulation is causing the error

openEMS - dumping PEC info to 'PEC_dump.vtk'
openEMS - disabling simulation => preprocessing only
Create FDTD operator (compressed SSE + multi-threading)
Operator: Dumping PEC information to vtk file: PEC_dump ... done.
FDTD simulation size: 45x45x66 --> 133650 FDTD cells
FDTD timestep is: 2.97452e-13 s; Nyquist rate: 1588 timesteps @1.05853e+09 Hz
openEMS::SetupFDTD: Warning, the timestep seems to be very small --> long simulation. Check your mesh!?
Excitation signal length is: 48156 timesteps (1.43241e-08s)
Max. number of timesteps: 1000000000 ( --> 20765.8 * Excitation signal length)
error: openEMS binary exited with error-code 1
error: called from
invoke_openEMS at line 50 column 2
RunOpenEMS at line 181 column 9
helix at line 134 column 5

Script line is
RunOpenEMS( Sim_Path, Sim_CSX, '--debug-PEC --no-simulation');

Any thoughts?

Thanks.

MPC

thorsten
Posts: 1479
Joined: Mon 27 Jun 2011, 12:26

Re: Ubuntu --no-simulation option in RunOpenEMS does not work

Post by thorsten » Mon 06 Sep 2021, 19:11

Well it works, but openEMS just returns an exit code "1" in this case. I guess Octave thinks of this as an error...
But at the same time this is not too bad as continuing with the script without results may not be very useful?

regards
Thorsten

Post Reply