InitCSX: not recognized

Install support for openEMS

Moderators: thorsten, sebastian

Post Reply
felipebm
Posts: 23
Joined: Wed 10 Dec 2014, 14:15

InitCSX: not recognized

Post by felipebm » Wed 10 Dec 2014, 14:49

Hi to all,

I just tried the Tutorial: Fist Steps and everything went fine, except for the CSXCAD test:

>> InitCSX
??? Undefined function or variable 'InitCSX'.

This is the way I'd installed it:

Since I have Debian 7.0 (Wheezy) installed in my PC, I looked if the repository includes an installer for my OS and it does!
although it is not shown in the wiki's installation section.

I added the repository for Debian 7.0 and installed openems and appcsxcad without any error or warning message.

This are the commands I used to add the repository:

Code: Select all

wget -O- 'http://download.opensuse.org/repositories/home:/sibbi77:/openEMS/Debian_7.0/Release.key' 2>/dev/null | apt-key add -
echo 'deb http://download.opensuse.org/repositories/home:/sibbi77:/openEMS/Debian_7.0/ /' > /etc/apt/sources.list.d/openems.list
and then to installed openEMS:

Code: Select all

apt-get update
apt-get install openems appcsxcad paraview
Please, can you tell what is wrong with my installation?

Thanks,
Felipe.

sebastian
Posts: 114
Joined: Mon 27 Jun 2011, 12:36
Contact:

Re: InitCSX: not recognized

Post by sebastian » Wed 10 Dec 2014, 21:42

Hi,

did you add the install path to octave?
Try:

Code: Select all

addpath('/usr/share/CSXCAD/matlab');
If this does not work either, check if the InitCSX.m file is present in /usr/share/CSXCAD/matlab.

Sebastian

felipebm
Posts: 23
Joined: Wed 10 Dec 2014, 14:15

Re: InitCSX: not recognized

Post by felipebm » Thu 11 Dec 2014, 14:46

Sebastian,

thanks a lot!
Now it seems so obvious. :oops:

I did not include it since it does not appear on the Debian 6.0 Squeeze installation instructions.

I'd updated the wiki with these instructions for Debian 7.0. Hope that helps.

Thanks again,
Felipe.

Post Reply