Raspbian OS 64bit build. Nearly, but not quite!

Install support for openEMS

Moderators: thorsten, sebastian

Post Reply
Posts: 31
Joined: Thu 23 May 2019, 18:05

Raspbian OS 64bit build. Nearly, but not quite!

Post by smerrett79 » Tue 07 Jul 2020, 11:29

Hi everyone,

Rather than necro this thread which I started last year, the recent release of a Raspberry Pi OS 64bit beta and the recent progress on booting pi4 from USB3.0 means I thought it would be worth trying again. I have hit some errors in make (having avoided the issues I worked around in the previous thread). I would like to say thanks to @thorsten and @kdv (sorry - I didn't see your replies on the previous thread) for all their support so far.

As we know, vtk5 isn't available so we can choose from vtk6.3 or vtk7 (7.1.1 at the moment, I think).
I managed to get quite far through the build but the logs (attached for each version of vtk tried) show that the compiler is trying to access files that haven't been placed in the locations specified.

I think it is failing at this line:

Code: Select all

# vtk
find_package(VTK COMPONENTS vtkIOXML vtkIOGeometry vtkIOLegacy vtkIOPLY NO_MODULE REQUIRED)
I have attached the VTKTargets.cmake file that is referenced in the error (renamed to a .txt extension so it could be uploaded to the forum).

I have had a quick look in CMakeLists.txt in

Code: Select all

and, being unfamiliar with them, aren't sure if there's anything in there which could be changed to avoid this error. I have tried compiling without GUI in case it would spare me from having to compile vtk (I would be able to accept if this only ran in the command line, although AppCSXCAD would be nice, to verify models have been correctly made).

After the failure of vtk build, I fall foul of the

Code: Select all

message(FATAL_ERROR "Unsupported target architecture!  Try porting openEMS to your architecture...")
. I did not have this issue when compiling for Raspberry Pi 4 (32bit) last year so I presume it is linked to the difference between Arm64 and armhf? Is there anything I can do in openEMS compilation or source files to address this?
renamed from VTKTargets.cmake
(143.13 KiB) Downloaded 604 times
Failed using vtk7
(21.89 KiB) Downloaded 627 times
Failed using vtk6.3
(20.3 KiB) Downloaded 621 times

Posts: 31
Joined: Thu 23 May 2019, 18:05

Re: Raspbian OS 64bit build. Nearly, but not quite!

Post by smerrett79 » Wed 22 Jul 2020, 01:49

So, the thread I didn't want to necro contained some answers towards this. Basically the vtk errors aren't going away but it's the conditional flags catching an unsupported architecture that's the issue to start with. Once you allow for an arm architecture, it seems to build without complaint, although you'll see on the other thread about Raspi building that I still have issues (which weren't there last year but are now, even though I tried not building from Github and using the wget from the openems.de website!)

Hopefully here or there, someone will have a little more insight for us.

Post Reply