Recover output voltage waveform wrong amplitude

How to use openEMS. Discussion on examples, tutorials etc

Moderator: thorsten

Post Reply
andres_A
Posts: 2
Joined: Wed 02 Dec 2020, 06:50

Recover output voltage waveform wrong amplitude

Post by andres_A » Fri 04 Dec 2020, 01:05

Hi,
I am trying to excite a microstrip circuit with a pulse and then recover the outgoing voltage wave. The circuit is a hairpin resonator, which is excited with a microstrip on the left, as seen in the picture below:
hairpin.png
hairpin.png (322.09 KiB) Viewed 1444 times
The input pulse is a Gaussian pulse with bandwidth 150MHz and central frequency 2GHz. The reflected wave should be of the same shape and almost the same amplitude as the input pulse because the pulse is narrowband and the hairpin resonates at 2GHz.

What I do is:
1) Excite the circuit and recover the total voltage from the field port{1}.ut.tot. Let this be Vtotal.
2) Use an identical microstrip as the one that feed the hairpin but end it in a PML layer. Then measure the incoming wave from the same field port{1}.ut.tot. Let this be Vin.The feed line is properly estimated to have a 50Ohm impedance.
3) Since the time steps are not the same, the signals are oversampled by 20 in InitFDTD and then Vin is linearly interpolated to the time step of Vtotal which is smaller.
4) Finally I substract:
Vout = Vtotal - Vin.

The problem is that the amplitude of the output pulse is larger than the input pulse: :oops:
output.gif
output.gif (451.29 KiB) Viewed 1444 times

I am attaching the code files but I think that my question is more general:
Should I use another signal to recover the voltage? Is there another way to do it?
Is there some rescaling of the Voltage signals using the time step or a reference impedance or something like that?

I have been going over this for a long time and I don't know what could be wrong.

Thank you very much.
Best regards,
Andrés
Attachments
sim_startar.m
Main file
(2.01 KiB) Downloaded 140 times

andres_A
Posts: 2
Joined: Wed 02 Dec 2020, 06:50

Re: Recover output voltage waveform wrong amplitude

Post by andres_A » Fri 04 Dec 2020, 15:04

I'm sorry I messed up the file upload. I attach the correct files now.

I have refined the grid but I still get the same results. I have looked at the CalcTLport and the excitations file in the source code but I see that the voltages are not normalized in any way.

I am surprised because I have ran a similar code in another open source FDTD implementation (gprMax) and I get a reasonable answer. I don't know what else to do.
Attachments
OpenEMS.zip
microstrip_sim is the infinite microstrip and hairpinQext is the hairpin simulation. Everything is run from main
(3.49 KiB) Downloaded 135 times

thorsten
Posts: 1438
Joined: Mon 27 Jun 2011, 12:26

Re: Recover output voltage waveform wrong amplitude

Post by thorsten » Sat 05 Dec 2020, 11:50

If you compare voltages of different simulations you need indeed normalize to "et" which is the excitation signal as this may have different amplitudes.
Normally you don't need to do this if you divide voltages of the same simulation as this cancels out.
But if you want to look at plain voltages or compare different simulations you need to do this.

I hope this helps
regards
Thorsten

Post Reply